When a string is a character, it can't be enclosed in quotes

I would like to have in my command line something like: -prefix "c" ; where c is an input of type string,
but when a string is only composed of a character, it doesn’t appear enclosed in quotes.
I tried things like this: valueFrom: \"$(inputs.empty_text)\" but then, it’s considered as a string so in the command line it became : -e \ '"."' because now quotes are part of the string…

Could you help me with this ?

Does the tool really need the c to be in quotes? When you enter commands to a shell (bash) the entire command is turned into an array of strings by the shell. Quotes can be used to group items to preserve spaces, this is why you have to quote any filenames that have a space in them. So application -prefix "c" -second-prefix "d e" becomes the array ["application", "-prefix", "c", "-second-prefix", "d e"] (using Python/JSON notation), but the literal quote characters are not passed to the application itself.

Alright I understand, I don’t really know, but without quotes it doesn’t take into account the option.
I will check out of cwl, and test the role of the quotes.

Hi @cjuigne - it seems to work without the quotes when I tried it. I made some comments on your PR for SnpSift , thanks for that! I know its been a while since that PR was submitted but I hope you can take a second look at https://github.com/common-workflow-library/bio-cwl-tools/pull/75.